formats

Pour les Windowsiens (personne n’est parfait), l’installation est présentée ici.

Avec le gestionnaire de package d’Ubuntu, on ne peut qu’obtenir la version 1.8 (par défaut) ou la version 1.9.1 qui ne sont plus supportées par Ruby.

 

Si vous avez fait comme moi une installation foireuse, il va falloir faire machine arrière comme ça :

sudo apt-get –purge remove ruby-rvm sudo rm -rf /usr/share/ruby-rvm /etc/rvmrc /etc/profile.d/rvm.sh

Du coup, la commande suivante ne devrait pas vous donner de résultats :

env | grep rvm

 

Ensuite on installe le gestionnaire de paquets Ruby (RVM) avec ce script :

curl -L get.rvm.io | bash -s stable –auto

source /usr/local/rvm/scripts/rvm

 

Puis la dernière version du gestionnaire de paquets gems.

rvm rubygems latest

 

Puis on installe rails gràce à gem :

gem install rails

 

Et enfin, en tant que root on installe un environnement d’exécution Javascript Node.JS :

apt-get install python-software-properties
apt-add-repository ppa:chris-lea/node.js
apt-get update
apt-get install nodejs npm

 

La prochaine fois, on fera un Hello World !

 

Sur le même sujet :