AdminRezo

Systèmes, réseaux, web

Si vous suivez mon blog, vous savez pourquoi Ansible, c’est bien, comment l’installer et le tester. Maintenant on va passer aux choses sérieuses : Utiliser les playbooks.   Playbooks ???   Les playbooks sont des scénarii dans lesquels sont décrits […]

J’ai présenté l’autre jour Ansible comme une très bonne solution d’automatisation. Ansible fonctionne par SSH avec des scripts écrits en Python. Il n’y a pas d’installation d’agent. J’utilise quand même le terme « serveur » pour la machine sur laquelle Ansible est […]

Il m’arrive de me servir de PacketTracer pour tester des équipements réseau sans avoir à les virtualiser avec gns3. PacketTracer a deux défauts : – Il n’est pas libre et est réservé aux étudiants Cisco (sauf sa nouvelle version Android) […]

C’est fait, mes serveurs sont administrés avec Ansible. Pour ceux qui ne le connaisse pas, Ansible est un outil d’automatisation de serveurs. Logiciel libre, écrit en Python, à destination des serveurs sous Unix/Linux et maintenant également sous Windows. Ansible est […]

Ça y est, l’académie Cisco est passée à l’ère des tablettes. Il existe désormais un Packet Tracer pour Android, disponible sur Google Play. Il faut voir si c’est utilisable car jusqu’à preuve du contraire, Packet Tracer n’est pas franchement à […]

Depuis la version 15 de l’iOS, il est possible de s’authentifier sur un équipement Cisco sans mot de passe mais avec des clés SSH. A utiliser, par exemple, pour automatiser avec expect.   Sur le PC (ça devrait déjà être […]

Il est fréquent de recourir à Git quand on se met à coder des projets ou pourquoi pas pour faire un Wiki. J’avais déjà parlé d’auto-héberger son Git et j’avais évoqué la commande git instaweb qui génère une page Web […]

Comme certains d’entre vous, j’ai passé une partie de mon jeudi à mettre à jour des bash dans mes différents Linux (et je vous passe les BSD, HP-UX et autres joyeusetés). Sur les matériels réseau, j’avais déjà parlé d’expect, une […]

Une grosse faille de sécurité a été découverte dans bash. Tous les systèmes Linux actuels sont touchés. Le bulletin Debian et celui de RedHat. Pour savoir si vous êtes concerné : env x='() { :;}; echo vulnerable’ bash -c « echo […]