Redistribution de routes OSPF – BGP

 

Dans les réseaux locaux, l’un des protocoles de routage les plus utilisés est OSPF. Il est l’un des plus fiables, notamment parce qu’il utilise l’algorithme de Dijkstra qui permet de choisir le chemin le plus court tout en pondérant les routes possibles.

D’autre part, ce n’est pas un protocole propriétaire, il est normalisé donc on le retrouve sur tous les routeurs.

Entre systèmes autonomes (entre entreprises), le protocole de routage le plus utilisé est eBGP.

 

BGP apprend les routes externes.

OSPF apprend les routes internes.

Comment faire connaître au réseau public un réseau privé ? En redistribuant les routes d’un protocole vers l’autre.

 

Un exemple de mise en oeuvre (d’après le schéma ci-dessus) :

Plan d’adressage :

 

Router 1 (OSPF + BGP) :

lo0 : 1.1.1.124

g0/0 : 10.1.0.224

g0/1 : 192.168.0.124

 

Router 2 (OSPF + BGP) :

lo0 : 2.2.2.224

g0/0 : 192.168.0.224

g0/1 : 10.3.0.124

 

Router 3 (OSPF + BGP) :

lo0 : 3.3.3.324

g0/0 : 192.168.0.324

g0/1 : 10.2.0.224

 

Router 4 (OSPF + BGP) :

lo0 : 4.4.4.424

g0/0 : 192.168.0.424

g0/1 : 10.4.0.124

 

Router 5 (OSPF) :

lo0 : 5.5.5.524

g0/0 : 10.1.0.124

g0/1 : 10.2.0.124

 

Router 6 (OSPF) :

lo0 : 6.6.6.624

g0/0 : 10.3.0.224

g0/1 : 10.4.0.224

 

Un exemple de redirection de route pour le routeur 1 :


!
router ospf 1
redistribute bgp 100
passive-interface GigabitEthernet0/1
network 10.1.0.0 0.0.0.255 area 1
network 1.1.1.0 0.0.0.255 area 1
!
router bgp 100
neighbor 192.168.0.2 remote-as 200
neighbor 192.168.0.4 remote-as 200
network 192.168.0.0
network 1.1.0.0 mask 255.255.0.0
redistribute ospf 1

 

Le fichier packet tracer complet.

Sur le même sujet :