Vous voulez une version plus récente : DotDeb

debian-apt

Avantage et inconvénient de Debian stable : Le gel des versions de logiciels qui a pour conséquence la stabilité, bien sûr, mais aussi l’impossibilité de mettre à jour pour question de fonctionnalité ou de sécurité (votre Debian est-elle sécurisée ?).

DotDeb est un dépôt géré par Guillaume Plessis qui fournit des logiciels serveurs plus récents. Le packaging est sur Github.

A utiliser avec précaution, mais ça peut être utile quand on a un besoin particulier (php5.6 pour ma part) :

Ajouter au fichier /etc/apt/sources.list les lignes :

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

Téléchargez les clés GPG qui vont bien :

wget http://www.dotdeb.org/dotdeb.gpg
apt-key add dotdeb.gpg
apt-get update

Encore mieux : vous pouvez préciser la version du logiciel dont vous avez besoin dans les sources (dans mon cas PHP 5.6) :

deb http://packages.dotdeb.org wheezy-php56 all
deb-src http://packages.dotdeb.org wheezy-php56 all

Sur le même sujet :